Desktop Qt based XMPP messenger
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
shunf4 a24e8382d1 correctly retrieve latest archived messages per XEP-0313 9 months ago
cmake add forgotten cmake/MacOSXBundleInfo.plist.in 9 months ago
core correctly retrieve latest archived messages per XEP-0313 9 months ago
external build: finish up CMakeLists refactoring 1 year ago
packaging Merge remote-tracking branch 'origin/master' into messageFeed 10 months ago
plugins build: plugins/, passwordStorageEngines/wrappers/ as shared libs 1 year ago
resources add icns to macos bundle; use macdeployqt post build 9 months ago
shared [Fix] Merge branch 'feat/adapt_win_osx' into upstream_messageFeed 9 months ago
translations translation verification 10 months ago
ui adjust CMakeLists.txt, to prepare for win32 and macos builds 9 months ago
.gitmodules debugging vanished messages 3 years ago
CHANGELOG.md highlight in directory now is optional runtime plugin to KIO, several more file managers to fallback, refactor, 2 new icons 1 year ago
CMakeLists.txt add icns to macos bundle; use macdeployqt post build 9 months ago
LICENSE.md started to devide contact and MUC, license, readme, attach icon 3 years ago
README.md update docs for win32 build 9 months ago
appveyor.yml fix ci for macos; adjust ci for linux executable with changed rpath 9 months ago
signalcatcher_win32.cpp adjust CMakeLists.txt, to prepare for win32 and macos builds 9 months ago

README.md

Squawk - a compact XMPP desktop messenger

AUR license AUR version Liberapay patrons

Squawk screenshot

Prerequisites

  • QT 5.12 (lower versions might work but it wasn't tested)
  • lmdb
  • CMake 3.0 or higher
  • qxmpp 1.1.0 or higher
  • KDE Frameworks: kwallet (optional)
  • KDE Frameworks: KIO (optional)
  • Boost

Getting

The easiest way to get the Squawk is to install it from AUR (if you use Archlinux like distribution)

Here is the link for the AUR package

You can also install it from console if you use some AUR wrapper. Here what it's going to look like with pacaur

$ pacaur -S squawk

Building

You can also clone the repo and build it from source

Squawk requires Qt with SSL enabled. It uses CMake as build system.

Please check the prerequisites and install them before installation.

For Windows (Mingw-w64) build

You need Qt for mingw64 (MinGW 64-bit) platform when installing Qt.

The best way to acquire library lmdb and boost is through Msys2.

First install Msys2, and then install mingw-w64-x86_64-lmdb and mingw-w64-x86_64-boost by pacman.

Then you need to provide the cmake cache entry when calling cmake for configuration:

cmake .. -D LMDB_ROOT_DIR:PATH=<Msys2 Mingw64 Root Directory> -D BOOST_ROOT:PATH=<Msys2 Mingw64 Root Directory>

<Msys2 Mingw64 Root Directory>: e.g. C:/msys64/mingw64.


There are two ways to build, it depends whether you have qxmpp installed in your system

Building with system qxmpp

Here is what you do

$ git clone https://git.macaw.me/blue/squawk
$ cd squawk
$ mkdir build
$ cd build
$ cmake .. [-D LMDB_ROOT_DIR:PATH=...] [-D BOOST_ROOT:PATH=...]
$ cmake --build .

Building with bundled qxmpp

Here is what you do

$ git clone --recurse-submodules https://git.macaw.me/blue/squawk
$ cd squawk
$ mkdir build
$ cd build
$ cmake .. -D SYSTEM_QXMPP=False [-D LMDB_ROOT_DIR:PATH=...] [-D BOOST_ROOT:PATH=...]
$ cmake --build .

You can always refer to appveyor.yml to see how AppVeyor build squawk.

List of keys

Here is the list of keys you can pass to configuration phase of cmake ...

  • CMAKE_BUILD_TYPE - Debug just builds showing all warnings, Release builds with no warnings and applies optimizations (default is Debug)
  • SYSTEM_QXMPP - True tries to link against qxmpp installed in the system, False builds bundled qxmpp library (default is True)
  • WITH_KWALLET - True builds the KWallet capability module if KWallet is installed and if not goes to False. False disables KWallet support (default is True)
  • WITH_KIO - True builds the KIO capability module if KIO is installed and if not goes to False. False disables KIO support (default is True)

License

This project is licensed under the GPLv3 License - see the LICENSE.md file for details